Recently we had a need to perform a ‘swing migration’ on a Mautic instance which was running 1.4 - we needed to migrate it to the latest version of Mautic, and also update PHP on the server.
Mautic has some in-built checks which are designed to prevent you from updating your Mautic version when there is an incompatible PHP version on the server. This means that if you are running Mautic 1.4, and you have a PHP version which is below the minimum required level for the next update, the only way to update Mautic is to upgrade your PHP version, and hope that Mautic will survive!
This wasn’t really an option for us in this instance, as our Mautic installation was in heavy production use, and the server had multiple other applications running which prevented us from updating PHP without extensive testing - so we needed to move it to our newer servers.
Have you been having problems with connecting via SSH since updating to Ubuntu 16.04? Me too!
This weekend I was trying to connect to a new server via SSH. I generated a key pair as usual, added it to my SSH Config file, uploaded the public key, but when I tried to connect I kept getting:
Permission denied (publickey)
Everything was set up correctly on the server, and strangely it wasn't even seeing my connection attempts in the logs.
Sometimes we come across a problem which has all of us scratching our heads and frantically searching to find what might be going on ... today was another of those moments!
Tools such as CPanel/WHM or Plesk make managing a server far easier for those who don't know how to use the shell. Arguably, they allow those outside of the tech sector to manage their own servers effectively and with minimal effort.
Where this falls down, however, is when setting a new server up. It's very easy to be lulled into a false sense of security, leaving your server potentially vulnerable to miscreants. In this post, I'll explain what the issues are, and why you should always seek help from someone familiar with configuring servers running your OS of choice (whether that be Linux, Windows, AIX or anything else!).
If you're on shared hosting, this article won't apply to you, as your host will have configured things for you, and even if they've done it wrong you lack the power to change it!
Joomla! 1.6 requires PHP 5.3 or later to be installed. When requesting a new server, this is far less of a problem as many will be provisioned with PHP 5.3 already installed. What should you do, however, if you are running a version of CentOS prior to 5.6 you will need to manually update PHP before Joomla 1.6 will install.
In fact, even with Joomla 1.5 you may experience issues if you are running an earlier version of PHP. The latest build of Akeeba Backup, for example, requires PHP 5.3.
This post will detail the method you need to use to update from PHP 5.1 or 5.2 to PHP 5.3 (Note: These instructions should not be followed to update from PHP4 unless you know exactly what you are doing!)
We received a call just after midnight from a server administrator who was having difficulties with his mail server - to the point that his international clients were unable to receive email at the middle of their peak period. Nobody else picked up the phone ... we did!